Mac Controller Issues



  • I was very excited to play this game based on the reviews and similarities that were drawn between AWL, Spelunky, and Rogue Legacy. Unfortunately, I’m a lazy bastard who likes to use a controller for these kinds of games … and who is cursed with owning a mac.

    Anyway, I’m using an Xbox360 controller which the game’s default controller mappings seem to be a bit screwed up in terms of movement with the D-pad and more importantly, aiming with the right analog stick. Furthermore, occasionally when you return to the game after pausing, the character is continuously firing swords in one direction and can’t be stopped! Is anyone else having these kinds of issues or is it just me? I haven’t dug very far to fix it myself as I was hoping someone might have a quick fix.

    Thanks!


  • LDG

    @spaceman_spiff Sorry to hear you’re having issues with the controller support. We’re with you on the laziness, we intended controllers to be the preferred input method for AWL. I know that the Xbox 360 controller works on Windows and I’m pretty sure I’ve tested it on Mac as well, but I’ll have to double check.

    Can you describe the D-pad issues a little more? Are the directions reversed or something?

    As for aiming, there are deadzone settings that can be accessed via Settings > Gamepad (from the pause menu or the title screen).



  • Hey, thanks for responding.

    I tried again just to double check the issues I was having and play around with the few deadzone settings. I can’t seem to get around it (at least with the in-game settings which is all I’ve tried). I also tried reinstalling without any change. It is a 3rd party (Rock Candy) 360 controller but it works fine in all the other controller supported games I’ve played (Rogue Legacy, F1-2013).

    So using the D-pad has the following results:
    Press Down => Move Up
    Press Left => Move Down
    Press Right => Move Left
    Press Up => Nothing

    The R analog stick is similarly malfunctioning. Pressing the ‘back’ button pauses the game (which may have been intended) and ‘start’ hides the UI.

    X, Y, B, and A all perform the correct actions but then using the Left Trigger results in constant firing to the left.

    Anyway, for now I’ll just play with the mouse and keyboard. Perhaps it’s something specific to the controller or OS I’m using.

    Thanks again.


Log in to reply