Windows 8.x - No Audio



  • Hey guys!

    AWL has a problem on Windows 8.x devices that are touch enabled-- there is no audio. The game works great on non-touch enabled devices (both my Windows 8.0 and Windows 8.1 desktops work fine). But on my touch enabled Windows 8.x devices (Samsung tablet and Dell laptop) the game runs without any audio.

    I dug around in the minified JavaScript source a while back and found an isTouch() check which switches the audio from ogg to mp3, and since there aren’t any mp3 tracks shipping in with the game, there is no audio to play. I e-mailed “horse” Blair about it, and he said it was probably was due to some code specific to iOS which was inadvertently causing the problem.

    Anyways, I was curious to see if this is on the road-map to address before launch. It won’t affect me much as I mostly game on my desktop at home, but it might affect other that have Windows 8 w/ touch support (ie those all-in-one PCs or tablets etc). If it doesn’t get addressed before launch you might want to list it as a compatibility issue so buyers don’t find out about it after trying to run the game themselves.

    Looking forward to the launch!


  • LDG

    Thanks for the reminder! I’ll see if I can get this fixed before launch as it should be a one or two line fix. (Famous last words…)

    If not, you’re right, we should be up front about the issue.



  • I’m also experiencing this issue on a non-touchscreen Windows 8.1 desktop PC. Does anyone know a workaround?


  • LDG

    I’m also experiencing this issue on a non-touchscreen Windows 8.1 desktop PC. Does anyone know a workaround?

    Oops, sorry @caseyclysm! That issue should have been fixed… what version of A Wizard’s Lizard is it that has no audio for you?



  • v1.0.130


  • LDG

    @Caseyclysm said:

    v1.0.130

    I’ve got Win 8.1 running on my desktop so I’ll give it a look tomorrow. If I can’t figure out what’s wrong I’ll probably send you a debug build so we can diagnose. Sorry for the inconvenience!



  • @geoffb No prob! Thank you! :D



  • Yeah, just tried it as well and got no sound on Win8.1. ;)
    Gonna use my Mac instead. Superior in every way, that one is.


  • LDG

    @Caseyclysm @svenardo

    I’ve been testing the game on my desktop running Win 8.1 and the audio seems to work fine for me (of course!). I’ll try to get a debug version built today and sent that out to you guys ASAP. I think I have an email address for @svenardo, but I’m not sure if I have yours, @Caseyclysm. Can you shoot me an email at geoff@lostdecadegames.com so I can reply with a download link when it’s ready?

    Thanks guys, sorry for the bugs!



  • No prob, I sent an email.



  • I would also like to get a build if possible-- I’ll send my e-mail address as well.



  • Is this still being worked on? Still no audio for me :(


  • LDG

    We’re working on a “Quality of Life” update that will fix this and many other issues but it won’t be ready for a few weeks. Sorry for the delay!


  • Tiger Hat

    Just bought the game, having the same issue. Version 1.0.185. It’s a desktop, 8.1 and I don’t have a touchscreen. However, I do notice in my computer properties that it has something about being touch enabled anyway… Well it says “Pen and Limited touch support with 20 touch points.”


  • LDG

    Sorry about that! I think we’ll have these issues fixed and pushed to Humble in April.


Log in to reply